티스토리 뷰

728x90
반응형

우선 장고를 설치할 가상환경으로 이동합니다. 

 conda activate 가상환경이름

 

 

 

 


 

구글링해보면 보통 pip3로 장고를 설치하시던데,

python --version
pip --version

 

저는 이 두 명령어를 쳐보니 python 3.6을 보고 있어서 pip로 진행하였습니다...!! 

pip는 파이썬 기반 패키지 라이브러리를 관리해주는 친구인데 (패키지 설치, 지우기, 리스트 보여주기 등)

pip는 파이썬 버전이 3보다 낮은 것, pip3는 파이썬 버전이 3이상인 것을 위해 있다고 알고 있습니다. 

(Pip is for python version less than 3. and pip3 is used when you want to install packages for python version 3 or higher.)

 

base 환경으로 바꿔서 python version을 검색해보면

python --version
python3 --version

python은 파이썬2,  python3은 파이썬3이 출력되고

 

pip --version
pip3 --version

pip는 파이썬 2를, pip3는 파이썬 3을 바라보고 있다고 출력됩니다.

 

pip list
pip3 list

 

pip와 pip3에 설치되어있는 패키지 리스트를 출력해봐도 두 결과가 다른 것을 볼 수 있습니다. 

 

 

 

근데 제가 만든 가상환경에서는 왜그런지 모르겠어요.....!!  

저처럼 파이썬이랑 pip 버전을 출력해보시고 가상환경의 파이썬 버전과 같은 버전을 바라보고 있는 pip 또는 pip3로 아래 명령어를 진행해주세요!! 

 


 

아래 명령어로 장고를 설치해주세요 

pip install django

 

 

잘 설치되었는지 확인하고 싶다면 

python 으로 들어가서 import django를 해보고 장고 버전을 출력해보세요!

 

728x90
반응형
댓글
댓글쓰기 폼